Java solution for Prime Checker HackerRank Problem
Problem Description :
You are given a class Solution and its main method in the editor. Your task is to create a class Prime. The class Prime should contain a single method checkPrime.
The locked code in the editor will call the checkPrime method with one or more integer arguments. You should write the checkPrime method in such a way that the code prints only the prime numbers.
Sample Input :
2
1
3
4
5
Sample Output :
2
2
2 3
2 3 5
Output Format :
There will be only four lines of output. Each line contains only prime numbers depending upon the parameters passed to checkPrime in the main method of the class Solution. In case there is no prime number, then a blank line should be printed.
Solution :
What is prime number?
A number that can be divided exactly only by itself and 1, for example 3, 5, 7....
So we have to create new class called Prime and method called checkPrime(). In checkPrime() method we have to use var-args for taking parameters.
Learn more about Var-args in details :
So lets see code.
Code Solution :
import java.io.*;
import java.util.*;
import java.text.*;
import java.math.*;
import java.util.regex.*;
import java.lang.reflect.*;
import static java.lang.System.in;
class Prime {
void checkPrime(int... numbers) {
for (int num : numbers) {
if (isPrime(num)) {
System.out.print(num + " ");
}
}
System.out.println();
}
boolean isPrime(int n) {
if (n < 2) {
return false;
}
for (int i = 2; i < n ; i++) {
if (n % i == 0) {
return false;
}
}
return true;
}
}
public class Solution {
public static void main(String[] args) {
try{
BufferedReader br=new BufferedReader(new InputStreamReader(in));
int n1=Integer.parseInt(br.readLine());
int n2=Integer.parseInt(br.readLine());
int n3=Integer.parseInt(br.readLine());
int n4=Integer.parseInt(br.readLine());
int n5=Integer.parseInt(br.readLine());
Prime ob=new Prime();
ob.checkPrime(n1);
ob.checkPrime(n1,n2);
ob.checkPrime(n1,n2,n3);
ob.checkPrime(n1,n2,n3,n4,n5);
Method[] methods=Prime.class.getDeclaredMethods();
Set<String> set=new HashSet<>();
boolean overload=false;
for(int i=0;i<methods.length;i++)
{
if(set.contains(methods[i].getName()))
{
overload=true;
break;
}
set.add(methods[i].getName());
}
if(overload)
{
throw new Exception("Overloading not allowed");
}
}
catch(Exception e)
{
System.out.println(e);
}
}
}
Solution Explanation :
- First import "static java.lang.System.in;" package for solving compile time error.
- Now we created class called Prime and method called checkPrime() inside Prime class.
- In checkPrime() method we are using Var-args as we discussed before. Var-args works same as Array. We can loop through given Var-args argument.
- Loop through number argument and call another method name isPrime() which returns boolean value based on given number is prime or not.
- In isPrime() method, check given number is greater than 2 or not. If it is less than 2 means it is not prime number.
- Now traverse through 2 to given number and check modulo of number % i, If answer is 0 that means number is not prime otherwise it is prime number.
Output Explanation :
number = [2, 1, 3, 4, 5]
- In first loop,
- input : 2
- output : 2
- 2 is prime number.
- In second loop,
- input : 2, 1
- output : 2
- 2 is prim number and 1 is not prime.
- In third loop,
- input : 2, 1, 3
- output : 2, 3
- 2 and 3 is prim number and 1 is not prime.
- In fourth loop,
- input : 2, 1, 3, 4
- output : 2, 3
- 2 and 3 is prim number and 1 and 4 is not prime.
- In second loop,
- input : 2, 1, 3, 4, 5
- output : 2, 3, 5
- 2, 3 and 5 is prim number and 1and 4 is not prime.
Output :
2
2
2 3
2 3 5
Happy Learning... Happy Coding...
Other HackerRank problem and solution in Java :
- Can You Access? HackerRank solution in Java | Inner Class in Java
- Java Lambda Expressions HackerRank solution with Explanation
Comments
Post a Comment